Nach Installtion Frontend "500 Internal Server Error"

Hi zusammen, das Frontend wird nicht geladen nach der nach der Neuinstallation. Rechte etc. sind gesetzt.
PHP 8.2

Hallo Stefan,

hast du vielleicht den Apto unter einer anderen Domain installiert, als du jetzt versuchst ihn aufzurufen?
Falls ja, kannst du dich im Backend mit dem „superadmin“-User einloggen und die Domain anpassen, dann sollte es eigentlich funktionieren.

Gib gerne mal Feedback ob es nun geht :slight_smile:

Gruß,
Michelle

Grüß Gott, ich habe auch den 500 Fehler. Lt. Log wird keine Index gefunden, die ist aber vorhanden, zumindest im Verzeichnis „web“. Hat da jemand eine Idee, woran dies liegen könnte?!

[Fri Dec 15 11:37:43.225246 2023] [authz_core:error] [pid 65084:tid 140578767431232] [client 139.144.150.23:35572] AH01630: client denied by server configuration: /home/users/xxxx/www/xxxx-bestattungen.de/server-status
[Fri Dec 15 14:37:51.341844 2023] [autoindex:error] [pid 65084:tid 140578784216640] [client 133.242.174.119:44838] AH01276: Cannot serve directory /home/users/xxxxx/www/xxxxx-bestattungen.de/: No matching DirectoryIndex (index.html,index.cgi,index.pl,index.php,index.xhtml,index.htm) found, and server-generated directory index forbidden by Options directive

Hi Michelle,
danke für die Antwort. Der Pfad der Domain ist richtig hinterlegt. Ich habe genau die gleich Fehlermedung in der Log Datei wie Willy. Ich habe alles nomals neu Installiert, es will einfach nicht die indesx.php finden. Bei der PHP Version habe ich mich verschrieben, es ist PHP 8.1
VG Stefan

Hallo,

zeigt eure angelegte Subdomain denn auf das web Verzeichnis? Dort liegt ja die index Datei.
Wo bzw wie genau versucht ihr die Domain aufzurufen, also mit welcher url?
Könnt ihr das Backend aufrufen, indem Ihr /backend aufruft?

Viele Grüße
Juliane

Hi hi, danke für die Rückmeldung. Es wurde direkt im Stamm der Domain installiert, also nicht als Subdomain. Das Vereichnis „web“ ist auch vorhanden, die index.php auch. Der Aufruf im Backend klappt ohne Probleme. Nur das Frontend (https://meinedomain.de/web) wird mir dem Fehler 500 qutiert.
VG Stefan

Hallo Stefan,

kannst du mal einen Screenshot der Fehlermeldung schicken?
Kannst du mal prüfen, was im Backend bei Domain eingetragen ist? Shopeinstellungen → Domain. Dies müsste deiner Frontendomain. Stimmen die überein?
Bekommst du im Frontend in der Konsole eine Fehlermeldung?

Viele Grüße
Juliane

Hallo! Passiert genauso bei meiner Neuinstallation. Backend funktioniert. Nur die Content-Snippet Seite und das Frontend lösen einen „500 internal server error“. Gibt es diesbezüglich einen Lösungsansatz?

Hallo,

wenn du mir eine genauere Fehlerbeschreibung gibst, können wir dir da mehr helfen. „500 internal Server“ ist zu allgemein um etwas genaues sagen zu können.

Was sagt denn die Fehlermeldung in der Konsole aus?
Ist die Domain im Backend eingetragen?
Welche php Version hast du?
Erfüllst du die Apto.ONE Systemvorraussetzungen ?
Installierst du auf einem Hosting oder lokal?

Gruß
Juliane

Hallo! Danke für die schnelle Antwort.

Die Konsole sagt:
GET https://subdomain.domain.it/install-latest/web/ 500 (/install-latest/web/:1)
Unchecked runtime.lastError: Could not establish connection. Receiving end does not exist. (subdomain.domain.it/:1)

Hänge dir hier auch noch den Server Error Log dazu.

{„message“:„Uncaught PHP Exception Apto\Base\Domain\Core\Model\FileSystem\Exception\FileSystemInvalidRootDirectoryException: "The defined filesystem root directory ‚/‘ does not exist or is not reachable." at /home/konfigurator/public_html/install-latest/vendor/apto-one/core/Apto/Base/Infrastructure/AptoBaseBundle/FileSystem/LocalFileSystem.php line 56“,„context“:{„exception“:{„class“:„Apto\Base\Domain\Core\Model\FileSystem\Exception\FileSystemInvalidRootDirectoryException“,„message“:„The defined filesystem root directory ‚/‘ does not exist or is not reachable.“,„code“:0,„file“:„/home/konfigurator/public_html/install-latest/vendor/apto-one/core/Apto/Base/Infrastructure/AptoBaseBundle/FileSystem/LocalFileSystem.php:56“}},„level“:500,„level_name“:„CRITICAL“,„channel“:„request“,„datetime“:„2024-01-22T14:55:25.691980+01:00“,„extra“:{}}
{„message“:„Warning: is_dir(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/konfigurator/:/opt/cpanel/ea-php81/root/usr:/usr/local/lib/php:/tmp:/etc/pki/tls/certs/ca-bundle.crt:/var/cpanel/php/sessions:/usr/local/bin/wp)“,„context“:{„exception“:{„class“:„ErrorException“,„message“:„Warning: is_dir(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/konfigurator/:/opt/cpanel/ea-php81/root/usr:/usr/local/lib/php:/tmp:/etc/pki/tls/certs/ca-bundle.crt:/var/cpanel/php/sessions:/usr/local/bin/wp)“,„code“:0,„file“:„/home/konfigurator/public_html/install-latest/vendor/apto-one/core/Apto/Base/Infrastructure/AptoBaseBundle/FileSystem/LocalFileSystem.php:55“}},„level“:300,„level_name“:„WARNING“,„channel“:„php“,„datetime“:„2024-01-22T14:55:25.685930+01:00“,„extra“:{}}
{„message“:„Warning: realpath(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/konfigurator/:/opt/cpanel/ea-php81/root/usr:/usr/local/lib/php:/tmp:/etc/pki/tls/certs/ca-bundle.crt:/var/cpanel/php/sessions:/usr/local/bin/wp)“,„context“:{„exception“:{„class“:„ErrorException“,„message“:„Warning: realpath(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/konfigurator/:/opt/cpanel/ea-php81/root/usr:/usr/local/lib/php:/tmp:/etc/pki/tls/certs/ca-bundle.crt:/var/cpanel/php/sessions:/usr/local/bin/wp)“,„code“:0,„file“:„/home/konfigurator/public_html/install-latest/vendor/apto-one/core/Apto/Base/Infrastructure/AptoBaseBundle/FileSystem/LocalFileSystem.php:49“}},„level“:300,„level_name“:„WARNING“,„channel“:„php“,„datetime“:„2024-01-22T14:55:25.685850+01:00“,„extra“:{}}
{„message“:„Warning: file_exists(): open_basedir restriction in effect. File(/custom.css) is not within the allowed path(s): (/home/konfigurator/:/opt/cpanel/ea-php81/root/usr:/usr/local/lib/php:/tmp:/etc/pki/tls/certs/ca-bundle.crt:/var/cpanel/php/sessions:/usr/local/bin/wp)“,„context“:{„exception“:{„class“:„ErrorException“,„message“:„Warning: file_exists(): open_basedir restriction in effect. File(/custom.css) is not within the allowed path(s): (/home/konfigurator/:/opt/cpanel/ea-php81/root/usr:/usr/local/lib/php:/tmp:/etc/pki/tls/certs/ca-bundle.crt:/var/cpanel/php/sessions:/usr/local/bin/wp)“,„code“:0,„file“:„/home/konfigurator/public_html/install-latest/vendor/apto-one/core/Apto/Base/Infrastructure/AptoBaseBundle/Template/TemplateLoader.php:345“}},„level“:300,„level_name“:„WARNING“,„channel“:„php“,„datetime“:„2024-01-22T14:55:25.677610+01:00“,„extra“:{}}
[2024-01-22T14:55:25.564023+01:00] deprecation.INFO: User Deprecated: Since symfony/security-core 5.4: The „IS_AUTHENTICATED_ANONYMOUSLY“ security attribute is deprecated, use „PUBLIC_ACCESS“ for public resources, otherwise use „IS_AUTHENTICATED“ or „IS_AUTHENTICATED_FULLY“ instead if you want to check if the request is (fully) authenticated. {„exception“:„[object] (ErrorException(code: 0): User Deprecated: Since symfony/security-core 5.4: The "IS_AUTHENTICATED_ANONYMOUSLY" security attribute is deprecated, use "PUBLIC_ACCESS" for public resources, otherwise use "IS_AUTHENTICATED" or "IS_AUTHENTICATED_FULLY" instead if you want to check if the request is (fully) authenticated. at /home/konfigurator/public_html/install-latest/vendor/symfony/security-core/Authorization/Voter/AuthenticatedVoter.php:89)“} []
[2024-01-22T14:55:25.563004+01:00] deprecation.INFO: User Deprecated: Since symfony/security-core 5.4: The „Symfony\Component\Security\Core\Authentication\AuthenticationTrustResolver::isAnonymous()“ method is deprecated, use „isAuthenticated()“ or „isFullFledged()“ if you want to check if the request is (fully) authenticated. {„exception“:„[object] (ErrorException(code: 0): User Deprecated: Since symfony/security-core 5.4: The "Symfony\Component\Security\Core\Authentication\AuthenticationTrustResolver::isAnonymous()" method is deprecated, use "isAuthenticated()" or "isFullFledged()" if you want to check if the request is (fully) authenticated. at /home/konfigurator/public_html/install-latest/vendor/symfony/security-core/Authentication/AuthenticationTrustResolver.php:38)“} []

Installation ist auf einem Hosting. Wie du sehen kannst auf einer subdomain. Dennoch verweist diese auf ein eigenes Hosting-paket bei dem die Daten im public_html Ordner liegen.

PHP 8.1

Systemvoraussetzungen sind soweit erfüllt. Backend funktioniert einwandfrei.

Habe gestern noch mit meinem Server-Support gesprochen und dieser meint, dass dies wohl der ausschlaggebende Punkt wäre.

Der Rootordner wird nicht gefunden, obwohl alles korrekt installiert und sein sollte.

„The defined filesystem root directory ‚/‘ does not exist or is not reachable.“ sagt aus, das das es nicht im root Verzeichnis ist, du dies aber so angegeben hast.

Bei der Installation wirst du gefragt, ob alles im root Ordner liegt. Dies hast du bestätigt. Aber dem scheint nicht so zu sein.

Du kannst das Rootverzeichnis im Nachhinein abändern, wenn du die env.local anpasst. Da gibt es den Eintrag „APTO_PUBLIC_FOLDER=“ . Diesen kannst du auf den tatsächlichen root Ordner anpassen. Dann sollte er es finden.

Ok habe ich versucht.
Egal welchen Pfad ich in die env.local eintrage, bleibt die Fehlermeldung die selbe. Als würde dieser Eintrag gar nicht erst berücksichtigt werden.

Habe folgende Pfade versucht:

Absoluter Root im Hosting:
/home/konfigurator/public_html/install-latest/web
Pfad ab den Ordner auf den die Domain zielt:
/install-latest/web

Aus Neugierde habe ich auch:
/konfigurator/public_html/install-latest/web
und
/public_html/install-latest/web
versucht.

Macht keinen Unterschied, die Fehlermeldung bleibt diese:

{„message“:„Uncaught PHP Exception Apto\Base\Domain\Core\Model\FileSystem\Exception\FileSystemInvalidRootDirectoryException: "The defined filesystem root directory ‚/‘ does not exist or is not reachable." at /home/konfigurator/public_html/install-latest/vendor/apto-one/core/Apto/Base/Infrastructure/AptoBaseBundle/FileSystem/LocalFileSystem.php line 56“,„context“:

Ich hab mich leider geirrt, was den Eintrag angeht. Es ist nicht APTO_PUBLIC_FOLDER sondern APTO_ROOT_DIRECTORY
Dieser steht standardmäßig nicht in der „env.local“, den kannst du aber einfach als letzte Zeile anhängen. Trag dort in deinem Fall: APTO_ROOT_DIRECTORY=‚/home/konfigurator/public_html‘ ein
oder
APTO_ROOT_DIRECTORY=‚/home/konfigurator/public_html/‘ ob der / am Ende des Pfades hin muss, oder nicht, musst du ausprobieren. Da bin ich mir gerade nicht sicher. Probiere es erstmal ohne. Speichern, hochladen, testen. Wenn das nicht geht, füge den Slash hinzu.

Denk dran, das du den Eintrag von APTO_PUBLIC_FOLDER wieder auf den Standard stellst, wie er war bevor du ihn geändert hast.

Das sollte dein Problem beheben.

Viel Erfolg und meld dich gerne wieder.

Gruß Juliane

Jetzt hats geklappt.
Zum vervollständigen diese Posts und der definitiven Lösung hänge ich hier den Inhalt meiner env.local an:

APTO_INSTALLER=disabled
SA_HASH=‚(generierter Hash Code)‘
APTO_PUBLIC_FOLDER=‚/install-latest/web‘
DATABASE_URL=‚meine Datenkank‘
APTO_ROOT_DIRECTORY=‚/home/konfigurator/public_html‘

Vielen Dank Juliane :slight_smile:

Super das es geklappt hat und danke für das Feedback und deine komplette env.local. :partying_face: :grin: :+1:

Als Hinweis für die Allgemeinheit, die Werte in APTO_PUBLIC_FOLDER & APTO_ROOT_DIRECTORY sind spezifisch für deine Installation. Das kann bei anderen Nutzern anders aussehen, je nach Installationsverzeichnis.

Wenn du weitere Fragen hast, meld dich gerne hier im Forum. :slight_smile:

Viele Grüße
Juliane

1 Like

Hätte da noch eine Frage… Kann man irgendwie einen Debug_Modus einschalten damit Fehler im Frontend ausgegebn werden?

Ja, kann man. Aber sicherheitshalber frag ich mal nach, benötigst du den zum Entwickeln oder hast du Fehler im Frontend die du prüfen willst?

Wieder Fehler im Frontend. Schildere kurz:

Nach der Neuinstallation ist das Frontend aufrufbar. > Ich klicke auf einen beliebiges Produkt (z.B. Fensterkonfigurator Step by Step) > der Konfigurator öffnet sich > trotz richtiger Eingaben in den Maßfeldern kann ich nicht „Auswählen“ und zum nächsten Schritt > ich gehe ich wieder zurück zu der Produktseite und mwähle nochmals das selbe oder ein anderers Produkt > Anstatt eines Konfigurators erscheinen nur mehr Kopfbereich und Fußbeeich der Seite. Der Konfigurator Bereich bleibt leer.

Habe daraufhin mal den Symfony Debug Modus aktiviert. Der gibt aber nur an dass die /custom.css nicht innerhalb des von base_dir zugelassenen Pfades liegt. Die Suche nach einer custom.css in der gesmten AptoOne Installation ergibt keinen Treffer. Sollte es die Datei geben? Wenn ja dann wo? Kann dieser Fehler die Ursache sein?

Habe dApto One mehrmals neu installiert. Mit neuer Datenbank oder mit der bereits vorhandenen. Immer der selbe Fehler. Das erste mal ist der Konfigurator sichtbar, daraufhin blockiert er sich und verschwindet für immer.

Wenn die Element-Validation nicht funktioniert, klingt eher nach einem Query Fehler. Das kann ein Fehler der Permission im Server sein. Aber ohne es zu sehen, schwer zu sagen. Wenn du mal nen Screenshot schickst oder einen Link zu deinem Konfigurator, kann man sich das genauer ansehen.

Die Datei custom.css gibt es bzw. kann es geben. Muss es aber nicht. Standardmäßig liefern wir keine in der Installation aus. Die kannst du aber selbst anlegen. Wie und wo kannst du hier nachlesen, wenn du magst: Benutzerdefiniertes CSS (custom.css)
Das sorgt aber nicht für den Absturz. Wenn du von einer Konfiguration zurück ins Menü gehst, kann es ab und an passieren, das die Produkte nicht geladen werden, das wird gerade gefixt. In diesem Fall hilft es die Seite neu zu laden.

Welche Version des Apto.ONE hast du denn gerade installiert? Wie du das rausfindest steht hier: Apto- & Plugin-Versionen herausfinden