Fehler bei neuer Installation

Hallo, bekomme ich nun neuerdings eine Fehlermeldung wenn ich die neue Version installieren möchte.

SQLSTATE[42000]: Syntax error or access violation: 1101 BLOB, TEXT, GEOMETRY or JSON column ‚motive_settings‘ can’t have a default value

Kennt wer den Fehler?

Hallo,

welche Datenbank nutzt du denn? Maria DB oder MySQL? Und in welcher Version? War die Datenbank leert?

Hast du eine ganz neue Installation ausgeführt oder gab es schon Daten in dem Projekt?

Viele Grüße
Juliane

Wir nutzen MySQL-Version 5.7.37. Die alte Installation wurde zuerst überschrieben und Datenbank überschrieben … da das nicht geklappt hat, frische Installation mit neuer Datenbank, ebenfalls gleicher Fehler.

War bei kir auch. Hab’s dann mit ner MariaDB versucht und siehe da, ging. :grin: Hoffe das hilft.

Alex hat recht und danke für den Hinweis.
Es scheint das der Fehler nur bei MySQL auftritt. Das wird gefixt. Aber bis dahin solltet ihr auf die MariaDB ausweichen. Ich geb hier bescheid wenn MySQL keinen Fehler mehr wirft.

Viele Grüße
Juliane

GIbt es bei der MariaDB irgendwelche Probleme wenn ich meinen Server umstellen lassen? Wir haben schließlich noch die alte Version v1.2.93

Wie meinst du das? Wenn dein Hosting MariaDB anbietet muss du nur eine neue Datenbank anlegen und dann diese Zugangsdaten beim Installer hinterlegen, eine Serverumstellung ist dafür nicht nötig. Ob eine ältere Version von MariaDB Probleme macht, kann ich nicht sagen.

Viele Grüße
Juliane

Wir haben noch die alte Version vom Apto V 1.2.93. Ein Updaten ist ohne großes eingreifen leider nicht möglich aufgrund der veränderten Datenstruktur und natürlich das ehemalige Lizenzmodell. PHP 8.1 wird von Apto Version 1 nicht überstützt. Deshalb war hier meine Frage, wenn ich meinen Server auf MariaDB umstellen lassen, ob mein alter Apto das überhaupt mitmacht. Ich hätte es ja vorher gerne getestet, aber leider kann ich meinen Apto V1 nicht einfach in einen neuen Bereich kopieren, da 1. Lizenz und zweiten … wo ändere ich die config daten?

Zur Struktur eines alten Apto.ONE kann ich nichts sagen. Php 8.1 unterstützt dieser aber definitiv nicht ohne das Anpassungen vorgenommen werden. Da es im Forum aber um die bereits umgestellten und OpenSource Konfiguratoren geht, ist es auch nicht die richtige Stelle um dies zu besprechen.

Wenn ich dich richtig verstehe, willst du 2 Konfiguratoren in deinem Hosting laufen lassen. Wenn das Hosting bereits MariaDB zur Verfügung stellt, aber keine aktive Datenbank hinterlegt hat, sollte es kein Problem darstellen eine MariaDB Datenbank zu verwenden und dem Installer diese Zugangsdaten mitzuteilen.
Solltest du aber planen die Datenbankserver von einem mysql Server durch einen mariadb Server zu ersetzen, davon würde ich abraten, da hier einiges mehr schief laufen kann. Da solltest du mit einem Datenbank Experten Rücksprache halten. In den mir bekannten Hostings werden immer beide Datenbankvarianten angeboten.

Viele Grüße
Juliane

Hallo Juliane,
zur Info für Dich und andere… man kann den Datenbankserver ohne Probleme wechseln. Es gab keine Probleme bei der Umstellung auf MariaDB. Unser Apto V1 läuft weiterhin tadelos.

1 Like

Hallo zusammen,

die Systemanforderungen haben sich dahingehend noch nicht geändert, oder?
MySQL wird immer noch nicht unterstütz. => zumindest bekomme ich die selbe Fehlermeldung beim Versuch die DB zu befüllen.

Liebe Grüße Andreas

Hallo Andreas,

bis jetzt wurde der Fehler bei MySQL noch nicht gefixt, wurde jedoch aufgenommen und wird noch behoben.

Gruß,
Michelle